Board index Equipment Film Cameras help need for a pentax Asahi SV

Film Cameras

help need for a pentax Asahi SV

gbentenza
 
Posts: 1

help need for a pentax Asahi SV

Post Sun Jan 04, 2009 11:40 am


i was just given a Pentax Asahi SV, my first time with a film camera in my hands. i just read the manual (http://www.cameramanuals.org/pentax_pdf ... sv_s1a.pdf) and put a film inside. found the multiple exposures and self timer and have been playing a bit, also with the B option for long exposures.
but after this experiments, suddenly the "rapid wing lever" became completely free as if there was no film inside. i tried to click another photo but it doesn't go. nothing works. what did i do? what should i do now?
i went to a dark place and checked that the film is ok and well put.
can u help me please?

btw, i'm an artist who uses the camera not in a very technical way, so please don't be too technical :)
tk u and have a great new year!
GB

thazooo
 
Posts: 51

Re: help need for a pentax Asahi SV

Post Mon Jan 05, 2009 1:04 am


The 1st. thing I'd do is rewind the film into the canister and remove the film canister.
Once this is done close the camera back and see if the film advance has started working. If it has actuate the shutter and then repeat this several times.
Doing multiple exposures with the technique in the manual works well when the camera is new. As they get older, things stick. Removing the film and closing the
back resets everything.
If it continues to have the problem after you remove the film, time to have it serviced. The camera's a good old one and can be CLA'd if you can find a repair
shop.

Hope this helps.

Dana


Board index Equipment Film Cameras help need for a pentax Asahi SV

Who is online

Users browsing this forum: No registered users and 0 guests

cron