Board index PBase Questions and Answers Background color won't change

Questions and Answers

Background color won't change

Ask if you need help using PBase.
eagle01
 
Posts: 3

Background color won't change

Post Mon Jan 02, 2017 11:37 pm


Hi,all. Tried various hex #s for background and stays white,no color change when I 'update gallery.' Text works, but background stays white no matter if [color] or hex is used. Any help appreciated. Thanks! Have 'no style sheet' set,btw.

dw_thomas
 
Posts: 468

Re: Background color won't change

Post Tue Jan 03, 2017 12:52 am


Are you talking text area background or the field surrounding the images? In a quick look at my own stuff, I don't see a way to change colors except through using a style sheet.

(Here in this forum I see a 'Font colour' button, but I didn't even see that in the regular gallery editor.)

DaveT

eagle01
 
Posts: 3

Re: Background color won't change

Post Tue Jan 03, 2017 1:14 am


dw_thomas wrote:Are you talking text area background or the field surrounding the images? In a quick look at my own stuff, I don't see a way to change colors except through using a style sheet.

(Here in this forum I see a 'Font colour' button, but I didn't even see that in the regular gallery editor.)

DaveT


Thanks for reply. This would be the area surrounding the images. Here's a link to the gallery:

http://www.pbase.com/eagle01/photos_of_the_year_2016

In 'edit this gallery,' there are choices for background color and text color. While text color changes, the background color (here, white) stays the same, regardless of entering a color...e.g., 'gold,' or (hex).

Alan

dw_thomas
 
Posts: 468

Re: Background color won't change

Post Tue Jan 03, 2017 4:58 am


Bizarre (but then it is PBase), I tried the "Drop & Drag" editor which I normally use, and also the "Original" editor. In neither case do I see a color choice (maybe I need detailed directions to the command/button sequences to get there), so I tried switching to "No Style Sheet" thinking that might pop up different options, but still see no color choices. When I do that to one of my galleries, I get a black background. It appears there is a default .CSS file that loads, and then the customized user .CSS file, if there is one (which I normally use). If I look in "View source" and grab the default CSS file, I see some color specs, but even then what I see doesn't quite make sense -- and I see some of the same color settings from the default .CSS via your gallery or mine -- but the background colors are opposite! :shock:

I am not truly a web programmer, but I have at least a little working knowledge of it. Mayhaps I am misunderstanding the CSS code, something I know the least about. Or maybe Firefox 50.1.0 works differently than your browser?

(Methinks the smart machinery is beginning to outsmart itself!)
Good Luck -- maybe someone else here will have an idea. (Richo?!!!)
DaveT

eagle01
 
Posts: 3

Re: Background color won't change

Post Wed Jan 04, 2017 12:44 am


Thanks, Dave. Interesting. I'm a programming dummy, but like fooling with the (limited) pbase options for our galleries.

dw_thomas wrote:Bizarre (but then it is PBase), ...
Good Luck -- maybe someone else here will have an idea. (Richo?!!!)
DaveT

richo
 
Posts: 231

Re: Background color won't change

Post Wed Jan 04, 2017 5:26 am


eagle01 wrote:Hi,all. Tried various hex #s for background and stays white,no color change when I 'update gallery.' Text works, but background stays white no matter if [color] or hex is used. Any help appreciated. Thanks! Have 'no style sheet' set,btw.


Colors in stylesheets will override both background and text color for a gallery. You will have to remove or edit the stylesheet.


Board index PBase Questions and Answers Background color won't change

Who is online

Users browsing this forum: No registered users and 0 guests